using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:[^_]+_){2})(?=_)";
string substitution = @"\1ZZZ";
string input = @"B_502_ZZZ_01
B_400__01";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}