use strict;
my $str = 'B_502_ZZZ_01
B_400__01';
my $regex = qr/((?:[^_]+_){2})(?=_)/p;
my $subst = '\\1ZZZ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";