import Foundation
let pattern = #"((?:[^_]+_){2})(?=_)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
B_502_ZZZ_01
B_400__01
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1ZZZ"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)