const regex = new RegExp('((?:[^_]+_){2})(?=_)', 'g')
const str = `B_502_ZZZ_01
B_400__01`;
const subst = `\1ZZZ`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);