re = /((?:[^_]+_){2})(?=_)/
str = 'B_502_ZZZ_01
B_400__01'
subst = '\\1ZZZ'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result