const regex = /\w*\/[^\/]*\/(?<my_field>\S*)\s*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\w*\\\/[^\\\/]*\\\/(?<my_field>\\S*)\\s*$', 'gm')
const str = `
datastore1/packer-centos6/packer-centos6
datastore1/packer-win12/packer-win12
datastore1/packer_centos6/packer_centos6
datastore1/packer_centos7/packer_centos7
datastore1/packer_ubuntu18/packer_ubuntu18
datastore1/packer_ubuntu20/packer_ubuntu20`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}