// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\w*\/[^\/]*\/(?<my_field>\S*)\s*$").unwrap();
let string = "
datastore1/packer-centos6/packer-centos6
datastore1/packer-win12/packer-win12
datastore1/packer_centos6/packer_centos6
datastore1/packer_centos7/packer_centos7
datastore1/packer_ubuntu18/packer_ubuntu18
datastore1/packer_ubuntu20/packer_ubuntu20";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}