$re = '/\w*\/[^\/]*\/(?<my_field>\S*)\s*$/m';
$str = '
datastore1/packer-centos6/packer-centos6
datastore1/packer-win12/packer-win12
datastore1/packer_centos6/packer_centos6
datastore1/packer_centos7/packer_centos7
datastore1/packer_ubuntu18/packer_ubuntu18
datastore1/packer_ubuntu20/packer_ubuntu20';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);