use strict;
my $str = '
datastore1/packer-centos6/packer-centos6
datastore1/packer-win12/packer-win12
datastore1/packer_centos6/packer_centos6
datastore1/packer_centos7/packer_centos7
datastore1/packer_ubuntu18/packer_ubuntu18
datastore1/packer_ubuntu20/packer_ubuntu20';
my $regex = qr/\w*\/[^\/]*\/(?<my_field>\S*)\s*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}