import re
regex = re.compile(r"\w*\/[^\/]*\/(?<my_field>\S*)\s*$", flags=re.MULTILINE)
test_str = ("\n"
"datastore1/packer-centos6/packer-centos6 \n"
"datastore1/packer-win12/packer-win12 \n"
"datastore1/packer_centos6/packer_centos6 \n"
"datastore1/packer_centos7/packer_centos7 \n"
"datastore1/packer_ubuntu18/packer_ubuntu18 \n"
"datastore1/packer_ubuntu20/packer_ubuntu20")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")