#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?:\$*)(\s*)some latex(\s*)(?:\$*)"
Local $sString = "$some latex$" & @CRLF & _
"" & @CRLF & _
"$$" & @CRLF & _
"some latex" & @CRLF & _
"$$" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = "{% math %}\1some latex\2{% endmath %}"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)