const regex = /(?:\$*)(\s*)some latex(\s*)(?:\$*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\$*)(\\s*)some latex(\\s*)(?:\\$*)', 'g')
const str = `\$some latex\$
\$\$
some latex
\$\$
`;
const subst = `{% math %}\1some latex\2{% endmath %}`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);