re = /(?:\$*)(\s*)some latex(\s*)(?:\$*)/
str = '$some latex$
$$
some latex
$$
'
subst = '{% math %}\\1some latex\\2{% endmath %}'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result