import re
regex = re.compile(r"(?:\$*)(\s*)some latex(\s*)(?:\$*)")
test_str = ("$some latex$\n\n"
"$$\n"
"some latex\n"
"$$\n\n\n")
subst = "{% math %}\\1some latex\\2{% endmath %}"
result = regex.sub(subst, test_str)
if result:
print(result)