// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:\$*)(\s*)some latex(\s*)(?:\$*)").unwrap();
let string = "$some latex$
$$
some latex
$$
";
let substitution = "{% math %}\\1some latex\\2{% endmath %}";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}