import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\$*)(\\s*)some latex(\\s*)(?:\\$*)";
final String string = "$some latex$\n\n"
+ "$$\n"
+ "some latex\n"
+ "$$\n\n\n";
final String subst = "{% math %}\\1some latex\\2{% endmath %}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}