$re = '/(?:\$*)(\s*)some latex(\s*)(?:\$*)/';
$str = '$some latex$
$$
some latex
$$
';
$subst = "{% math %}\1some latex\2{% endmath %}";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;