#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<h3 class="r"><a href="\/url?\?q\=(http.*)\/""
Local $sString = "<h3 class="r"><a href="/url?q=http://www.somedomain.com/args/">Some Title</a></h3>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")