import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<h3 class=\"r\"><a href=\"\\/url?\\?q\\=(http.*)\\/\"";
final String string = "<h3 class=\"r\"><a href=\"/url?q=http://www.somedomain.com/args/\">Some Title</a></h3>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}