$re = '/<h3 class="r"><a href="\/url?\?q\=(http.*)\/"/';
$str = '<h3 class="r"><a href="/url?q=http://www.somedomain.com/args/">Some Title</a></h3>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);