package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<h3 class="r"><a href="\/url?\?q\=(http.*)\/"`)
var str = `<h3 class="r"><a href="/url?q=http://www.somedomain.com/args/">Some Title</a></h3>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}