re = /<h3 class="r"><a href="\/url?\?q\=(http.*)\/"/
str = '<h3 class="r"><a href="/url?q=http://www.somedomain.com/args/">Some Title</a></h3>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end