// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<h3 class="r"><a href="\/url?\?q\=(http.*)\/""#).unwrap();
let string = "<h3 class=\"r\"><a href=\"/url?q=http://www.somedomain.com/args/\">Some Title</a></h3>";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}