const regex = /<h3 class="r"><a href="\/url?\?q\=(http.*)\/"/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<h3 class="r"><a href="\\\/url?\\?q\\=(http.*)\\\/"', '')
const str = `<h3 class="r"><a href="/url?q=http://www.somedomain.com/args/">Some Title</a></h3>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}