using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<h3 class=""r""><a href=""\/url?\?q\=(http.*)\/""";
string input = @"<h3 class=""r""><a href=""/url?q=http://www.somedomain.com/args/"">Some Title</a></h3>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}