using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<img.*src=""([^""]+)";
string input = @"<div dir=""ltr"" style=""text-align: left;"" trbidi=""on"">
<div style=""text-align: center;"">
<img border=""0"" height=""355"" src=""http://i.imgur.com/8OplH.png"" width=""728"">
</div>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}