import re
regex = re.compile(r"<img.*src=\"([^\"]+)")
test_str = ("<div dir=\"ltr\" style=\"text-align: left;\" trbidi=\"on\">\n"
"<div style=\"text-align: center;\">\n"
"<img border=\"0\" height=\"355\" src=\"http://i.imgur.com/8OplH.png\" width=\"728\">\n"
"</div>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")