const regex = /<img.*src="([^"]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<img.*src="([^"]+)', 'g')
const str = `<div dir="ltr" style="text-align: left;" trbidi="on">
<div style="text-align: center;">
<img border="0" height="355" src="http://i.imgur.com/8OplH.png" width="728">
</div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}