// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<img.*src="([^"]+)"#).unwrap();
let string = "<div dir=\"ltr\" style=\"text-align: left;\" trbidi=\"on\">
<div style=\"text-align: center;\">
<img border=\"0\" height=\"355\" src=\"http://i.imgur.com/8OplH.png\" width=\"728\">
</div>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}