package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<img.*src="([^"]+)`)
var str = `<div dir="ltr" style="text-align: left;" trbidi="on">
<div style="text-align: center;">
<img border="0" height="355" src="http://i.imgur.com/8OplH.png" width="728">
</div>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}