$re = '/<img.*src="([^"]+)/';
$str = '<div dir="ltr" style="text-align: left;" trbidi="on">
<div style="text-align: center;">
<img border="0" height="355" src="http://i.imgur.com/8OplH.png" width="728">
</div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);