#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)mailto:([a-zA-Z0-9_\.-]+@[\da-z\.-]+\.[a-z\.]{2,6})""
Local $sString = "<a href="mailto:asd@yahoo.com" class="spamspan">EMAIL@yahoo.com</a>" & @CRLF & _
"<a href="mailto:asd@yahoo.com" class="spamspan">EMAIL@yahoo.com</a>" & @CRLF & _
"" & @CRLF & _
"<a href="mailto:test@google.com" class="spamspan">EMAIL@yahoo.com</a>" & @CRLF & _
"" & @CRLF & _
"<a href="mailto:asd@yahoo.com" class="spamspan">EMAIL@yahoo.com</a>" & @CRLF & _
"" & @CRLF & _
"<a href="mailto:asd@yahoo.co.uk" class="spamspan">EMAIL@yahoo.com</a>" & @CRLF & _
"" & @CRLF & _
"<a href="mailto:mail@yahoo.com" class="spamspan">EMAIL@yahoo.com</a>" & @CRLF & _
"" & @CRLF & _
"<a href="mailto:myaddress@yahoo.com" class="spamspan">EMAIL@yahoo.com</a>" & @CRLF & _
"" & @CRLF & _
"<a href="mailto:asd@yahoo.com" class="spamspan">EMAIL@yahoo.com</a>" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")