$re = '/mailto:([a-zA-Z0-9_\.-]+@[\da-z\.-]+\.[a-z\.]{2,6})"/m';
$str = '<a href="mailto:asd@yahoo.com" class="spamspan">EMAIL@yahoo.com</a>
<a href="mailto:asd@yahoo.com" class="spamspan">EMAIL@yahoo.com</a>
<a href="mailto:test@google.com" class="spamspan">EMAIL@yahoo.com</a>
<a href="mailto:asd@yahoo.com" class="spamspan">EMAIL@yahoo.com</a>
<a href="mailto:asd@yahoo.co.uk" class="spamspan">EMAIL@yahoo.com</a>
<a href="mailto:mail@yahoo.com" class="spamspan">EMAIL@yahoo.com</a>
<a href="mailto:myaddress@yahoo.com" class="spamspan">EMAIL@yahoo.com</a>
<a href="mailto:asd@yahoo.com" class="spamspan">EMAIL@yahoo.com</a>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);