import Foundation
let pattern = #"mailto:([a-zA-Z0-9_\.-]+@[\da-z\.-]+\.[a-z\.]{2,6})""#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<a href="mailto:asd@yahoo.com" class="spamspan">EMAIL@yahoo.com</a>
<a href="mailto:asd@yahoo.com" class="spamspan">EMAIL@yahoo.com</a>
<a href="mailto:test@google.com" class="spamspan">EMAIL@yahoo.com</a>
<a href="mailto:asd@yahoo.com" class="spamspan">EMAIL@yahoo.com</a>
<a href="mailto:asd@yahoo.co.uk" class="spamspan">EMAIL@yahoo.com</a>
<a href="mailto:mail@yahoo.com" class="spamspan">EMAIL@yahoo.com</a>
<a href="mailto:myaddress@yahoo.com" class="spamspan">EMAIL@yahoo.com</a>
<a href="mailto:asd@yahoo.com" class="spamspan">EMAIL@yahoo.com</a>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)