import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "mailto:([a-zA-Z0-9_\\.-]+@[\\da-z\\.-]+\\.[a-z\\.]{2,6})\"";
final String string = "<a href=\"mailto:asd@yahoo.com\" class=\"spamspan\">EMAIL@yahoo.com</a>\n"
+ "<a href=\"mailto:asd@yahoo.com\" class=\"spamspan\">EMAIL@yahoo.com</a>\n\n"
+ "<a href=\"mailto:test@google.com\" class=\"spamspan\">EMAIL@yahoo.com</a>\n\n"
+ "<a href=\"mailto:asd@yahoo.com\" class=\"spamspan\">EMAIL@yahoo.com</a>\n\n"
+ "<a href=\"mailto:asd@yahoo.co.uk\" class=\"spamspan\">EMAIL@yahoo.com</a>\n\n"
+ "<a href=\"mailto:mail@yahoo.com\" class=\"spamspan\">EMAIL@yahoo.com</a>\n\n"
+ "<a href=\"mailto:myaddress@yahoo.com\" class=\"spamspan\">EMAIL@yahoo.com</a>\n\n"
+ "<a href=\"mailto:asd@yahoo.com\" class=\"spamspan\">EMAIL@yahoo.com</a>\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}