use strict;
my $str = '<a href="mailto:asd@yahoo.com" class="spamspan">EMAIL@yahoo.com</a>
<a href="mailto:asd@yahoo.com" class="spamspan">EMAIL@yahoo.com</a>
<a href="mailto:test@google.com" class="spamspan">EMAIL@yahoo.com</a>
<a href="mailto:asd@yahoo.com" class="spamspan">EMAIL@yahoo.com</a>
<a href="mailto:asd@yahoo.co.uk" class="spamspan">EMAIL@yahoo.com</a>
<a href="mailto:mail@yahoo.com" class="spamspan">EMAIL@yahoo.com</a>
<a href="mailto:myaddress@yahoo.com" class="spamspan">EMAIL@yahoo.com</a>
<a href="mailto:asd@yahoo.com" class="spamspan">EMAIL@yahoo.com</a>
';
my $regex = qr/mailto:([a-zA-Z0-9_\.-]+@[\da-z\.-]+\.[a-z\.]{2,6})"/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}