package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)mailto:([a-zA-Z0-9_\.-]+@[\da-z\.-]+\.[a-z\.]{2,6})"`)
var str = `<a href="mailto:asd@yahoo.com" class="spamspan">EMAIL@yahoo.com</a>
<a href="mailto:asd@yahoo.com" class="spamspan">EMAIL@yahoo.com</a>
<a href="mailto:test@google.com" class="spamspan">EMAIL@yahoo.com</a>
<a href="mailto:asd@yahoo.com" class="spamspan">EMAIL@yahoo.com</a>
<a href="mailto:asd@yahoo.co.uk" class="spamspan">EMAIL@yahoo.com</a>
<a href="mailto:mail@yahoo.com" class="spamspan">EMAIL@yahoo.com</a>
<a href="mailto:myaddress@yahoo.com" class="spamspan">EMAIL@yahoo.com</a>
<a href="mailto:asd@yahoo.com" class="spamspan">EMAIL@yahoo.com</a>
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}