re = /mailto:([a-zA-Z0-9_\.-]+@[\da-z\.-]+\.[a-z\.]{2,6})"/m
str = '<a href="mailto:asd@yahoo.com" class="spamspan">EMAIL@yahoo.com</a>
<a href="mailto:asd@yahoo.com" class="spamspan">EMAIL@yahoo.com</a>
<a href="mailto:test@google.com" class="spamspan">EMAIL@yahoo.com</a>
<a href="mailto:asd@yahoo.com" class="spamspan">EMAIL@yahoo.com</a>
<a href="mailto:asd@yahoo.co.uk" class="spamspan">EMAIL@yahoo.com</a>
<a href="mailto:mail@yahoo.com" class="spamspan">EMAIL@yahoo.com</a>
<a href="mailto:myaddress@yahoo.com" class="spamspan">EMAIL@yahoo.com</a>
<a href="mailto:asd@yahoo.com" class="spamspan">EMAIL@yahoo.com</a>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end