// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)mailto:([a-zA-Z0-9_\.-]+@[\da-z\.-]+\.[a-z\.]{2,6})""#).unwrap();
let string = "<a href=\"mailto:asd@yahoo.com\" class=\"spamspan\">EMAIL@yahoo.com</a>
<a href=\"mailto:asd@yahoo.com\" class=\"spamspan\">EMAIL@yahoo.com</a>
<a href=\"mailto:test@google.com\" class=\"spamspan\">EMAIL@yahoo.com</a>
<a href=\"mailto:asd@yahoo.com\" class=\"spamspan\">EMAIL@yahoo.com</a>
<a href=\"mailto:asd@yahoo.co.uk\" class=\"spamspan\">EMAIL@yahoo.com</a>
<a href=\"mailto:mail@yahoo.com\" class=\"spamspan\">EMAIL@yahoo.com</a>
<a href=\"mailto:myaddress@yahoo.com\" class=\"spamspan\">EMAIL@yahoo.com</a>
<a href=\"mailto:asd@yahoo.com\" class=\"spamspan\">EMAIL@yahoo.com</a>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}