#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(.*)(?:\?s=.*)"
Local $sString = "urunler/cocuk/kiyafet/urun-ozet.php?s=ayakkabi-model-1.php" & @CRLF & _
"urunler/ev/mutfak-esyalari/urun-detayi.php?s=celik-tencere-model-1.php" & @CRLF & _
"urunler/elektronik/modem/urun-siparisi.php?s=modem-model-1.php" & @CRLF & _
"wmaraci.com/forum/uyeler.php?s=barisyilmaz/" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")