import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*)(?:\\?s=.*)";
final String string = "urunler/cocuk/kiyafet/urun-ozet.php?s=ayakkabi-model-1.php\n"
+ "urunler/ev/mutfak-esyalari/urun-detayi.php?s=celik-tencere-model-1.php\n"
+ "urunler/elektronik/modem/urun-siparisi.php?s=modem-model-1.php\n"
+ "wmaraci.com/forum/uyeler.php?s=barisyilmaz/\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}