import re
regex = re.compile(r"(.*)(?:\?s=.*)", flags=re.MULTILINE)
test_str = ("urunler/cocuk/kiyafet/urun-ozet.php?s=ayakkabi-model-1.php\n"
"urunler/ev/mutfak-esyalari/urun-detayi.php?s=celik-tencere-model-1.php\n"
"urunler/elektronik/modem/urun-siparisi.php?s=modem-model-1.php\n"
"wmaraci.com/forum/uyeler.php?s=barisyilmaz/\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")