$re = '/(.*)(?:\?s=.*)/m';
$str = 'urunler/cocuk/kiyafet/urun-ozet.php?s=ayakkabi-model-1.php
urunler/ev/mutfak-esyalari/urun-detayi.php?s=celik-tencere-model-1.php
urunler/elektronik/modem/urun-siparisi.php?s=modem-model-1.php
wmaraci.com/forum/uyeler.php?s=barisyilmaz/
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);