use strict;
my $str = 'urunler/cocuk/kiyafet/urun-ozet.php?s=ayakkabi-model-1.php
urunler/ev/mutfak-esyalari/urun-detayi.php?s=celik-tencere-model-1.php
urunler/elektronik/modem/urun-siparisi.php?s=modem-model-1.php
wmaraci.com/forum/uyeler.php?s=barisyilmaz/
';
my $regex = qr/(.*)(?:\?s=.*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}