// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(.*)(?:\?s=.*)").unwrap();
let string = "urunler/cocuk/kiyafet/urun-ozet.php?s=ayakkabi-model-1.php
urunler/ev/mutfak-esyalari/urun-detayi.php?s=celik-tencere-model-1.php
urunler/elektronik/modem/urun-siparisi.php?s=modem-model-1.php
wmaraci.com/forum/uyeler.php?s=barisyilmaz/
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}