using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\\)(\\[\w\.\-_]+){2,}(\\?)$";
string input = @"\\computer-name\drive\optional_folder1\optional_folder2\
\\computer_name\drive\optional_folder1\
\\computer-name\drive\
\\192.168.1.1\drive\
\\computer-name\\drive\
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}