re = /^(\\)(\\[\w\.\-_]+){2,}(\\?)$/m
str = '\\\\computer-name\\drive\\optional_folder1\\optional_folder2\\
\\\\computer_name\\drive\\optional_folder1\\
\\\\computer-name\\drive\\
\\\\192.168.1.1\\drive\\
\\\\computer-name\\\\drive\\
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end