import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\\\)(\\\\[\\w\\.\\-_]+){2,}(\\\\?)$";
final String string = "\\\\computer-name\\drive\\optional_folder1\\optional_folder2\\\n"
+ "\\\\computer_name\\drive\\optional_folder1\\\n"
+ "\\\\computer-name\\drive\\\n"
+ "\\\\192.168.1.1\\drive\\\n"
+ "\\\\computer-name\\\\drive\\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}