// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\\)(\\[\w\.\-_]+){2,}(\\?)$").unwrap();
let string = "\\\\computer-name\\drive\\optional_folder1\\optional_folder2\\
\\\\computer_name\\drive\\optional_folder1\\
\\\\computer-name\\drive\\
\\\\192.168.1.1\\drive\\
\\\\computer-name\\\\drive\\
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}