import re
regex = re.compile(r"^(\\)(\\[\w\.\-_]+){2,}(\\?)$", flags=re.MULTILINE)
test_str = ("\\\\computer-name\\drive\\optional_folder1\\optional_folder2\\\n"
"\\\\computer_name\\drive\\optional_folder1\\\n"
"\\\\computer-name\\drive\\\n"
"\\\\192.168.1.1\\drive\\\n"
"\\\\computer-name\\\\drive\\\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")